[Dock-fans] ERROR while runing the demo and other issues

Amit amit.mor at weizmann.ac.il
Tue Jul 12 09:35:59 PDT 2005


Dear dock-fans,

I'm new at the docking field ... and with using DOCK.
I'm currently using DOCK 5.2.
I have two major problems:
--------
1) I've encountered this error message when I tried to run the demo 
"grid.in" with the modification of 'chemical matching' option set to 'yes':
"ERROR get_chemical_labels: <null> specified if 
/software/graphics/DOCK/dock.5.2_Linux/parameters/chem.defn"

This error message has appeared when I tried to calculate my receptor 
grid with the same modification in the "grid.in" - which led me to try 
the same thing with the demo.

DOCK works fine with my actual receptor-ligand system (in some cases - 
see the second section) when the chemical matching is not used for the 
grid calculation.

What might be the problem ?

--------
2) I have been getting the 'segmentation fault' message  for a lot of my 
runs. 
To  isolate the problem I've used the demo's "dock.in" file and kept 
going with it till I've reached the point were DOCK is able to finish 
its calculations.

My ligands are peptides  with inter-strand disulfide bonds.

Docking was only made possible when I had broken these bonds and turned 
the cystine into 2 separate cysteines. I have changed the CYS to CYX 
(back and forth) and it didn't resolve the segmentation fault.

What does this error message is meant to say in my case. Is it just 
impossible to dock this peptide if regarding it as a "flexible ligand" ?
--------

Sorry for the length of things written here and thanks for your time and 
effort, of course - in advance,
Amit



More information about the Dock-fans mailing list