[Dock-fans] DOCK 6 installation -reg

Scott Brozell sbrozell at scripps.edu
Thu May 10 17:05:24 PDT 2007


Hi,

On Thu, 10 May 2007, John J. Irwin wrote:

> Are you really using RedHat 4.2?
> I suggest you upgrade to a more recent version. We use Fedora Core 4, 5
> or 6.
>
> Abdul Hameed, MohamedDiwanMo wrote:
> >
> > I am trying to install DOCK 6 on Linux (redhat 4.2).
> >
> > Initially I had problems with flex and yacc. But after installing flex
> > and bison, I am able to complete the installation of dock.
> >
> > During the installation process I am getting the warning message
> > (given below), particularly about an incompatible pointer type.
> >
> > Can we ignore this warning?


Yes.

> > Is there any particular reason to get this warning message? If someone
> > can suggest why we get this, it will be very helpful.
> >
> > / In file included from
> > /usr/lib/gcc/i386-redhat-linux/3.4.4/../../../../include/c++/3.4.4/backward/strstream:51,
> > /                  from sphere_selector.cpp:7: /
> > /
> > /usr/lib/gcc/i386-redhat-linux/3.4.4/../../../../include/c++/3.4.4/backward/backward_warning.h:32:2:
> > warning: #warning This file includes at least one deprecated or
> > antiquated header. Please consider using one of the 32 headers found
> > in section 17.4.1.2 of the C++ standard. Examples include substituting
> > the <X> header for the <X.h> header for C++ includes, or <iostream>
> > instead of the deprecated header <iostream.h>. To disable this warning
> > use -Wno-deprecated. /


As indicated strstream may be removed from a future C++ standard.
We have updated some but not all of DOCK to use the preferred sstream.

> > / residue.c: In function `ResidueConnect': /
> >
> > / residue.c:336: warning: passing arg 1 of `AtomBondTo' from
> > incompatible pointer type /
> >
> > / residue.c:336: warning: passing arg 2 of `AtomBondTo' from
> > incompatible pointer type /

All these come from Amber's LEaP program.
Someday they will be eliminated...

Scott



More information about the Dock-fans mailing list