[Dock-fans] Segmentation fault on running docking

Francesco Pietra chiendarret at yahoo.com
Wed Nov 7 07:30:41 PST 2007


Having solved empirically, whitout external help, the problem (posted on last
week-end) of running grid when residue HOH is present within the pore, I am now
faced by segfault in running rigid docking. That occurs both on parallel and
serial run. It also occurs with previous files for the protein without HOH,
where both rigid and flex run OK on mpirun -np 4. Thus, it seems that there is
now something wrong with dock6 and I don't understand what. 

Before these unsuccessful attempts, I had
(1) Unsuccessfully tried to recompile Antechamber with new respgen.c (on
Amber9), which did not affect previous compilation.
(2) Carried out "apt-get update" to Debian Linux amd64 etch (i.e., stable)
without taking notice of the little that was affected.
---------------

While running:

mpirun -np 4 -i rigid.in -o rigid.out

the process halted (rigid_scored.mol2 0 bytes) because

Initialing MPI routines ....
[deb64:03540] *** Process received signal ***
[deb64:03540] Signal: Segmentation fault (11)
[deb64:03540] Signal code: Address not mapped (1)
[deb64:03540] Failing at address: 0x2b9ef5691000
dock6.mpi[3540]: segfault at 00002b9ef56910000 rip 0000000000447b1b rsp
00007fff43c137b0 error 6
[deb64:03540] [0] /lib/libthread.so.0 [0x2b9e681bc410]
[deb64:03540] [1] dock6.mpi (_ZN60rient12match_ligandER7DOCKMol+0x40b)
[0x447b1b]
[deb64:03540] [2] dock6.mpi (main+0xaf5) [0x42cc75]
[deb64:03540] [3] dock6.mpi /lib/libc.so.6(__libc_start_main+0xda)
[0x2b9e682e14ca]
[deb64:03540] [4] dock6.mpi (__gxx_personality_v0+0xc2) [0x41b4ea]
[deb64:03540] *** End of error message ***
mpirun noticed that jpb rank 0 with PID 3537 on node deb64 exited on signal 15
(Terminated).
3 additional processes aborted (not shown)
---------------------------

I tried also flex with the protein endowed of HOH

mpirun -np 4 -i anchor_and_grow.in -o anchor_and_grow.out 2>&1 | tee errors.out

with an even more complex of libraries and mpi problems (see please attachment.
------------------

Parallel dock had so far run correctly. DOCK6.1 had been compiled with:

./configure gnu parallel
MPICH_HOME=/usr/local
export MPICH_HOME
make dock

I have now unsuccessfully deselected $AMBERHOME in my .bashrc, as expected
because it should be only relevant to running amber_score. I did not change
otherwise my .bashrc, where

DOCK_HOME=/usr/local/dock6
PATH=$PATH:$DOCK_HOME/bib; export DOCK_HOME PATH

MPI_HOME=/usr/local
export MPI_home

I have now tried the test

cd test/mpi
make 2>&1 | tee test_parallel.out
which passed OK.

Also:

which mpicxx
/usr/local/bin/mpicxx

Also:


updatedb
locate mpi.h
/usr/include/sc/util/group/memmtmpi.h
/usr/include/sc/util/group/messmpi.h
/usr/dock6/src/dock/base_mpi.h
/usr/local/include/mpi.h
/usr/local/openmpi-1.2.3/ompi/include/mpi.h
/usr/local/openmpi-1.2.3/ompi/include/mpi.h.in
/usr/local/openmpi-1.2.3/ompi/mpi/f77/prototypes_mpi.h

-----------------------
Also on serial trial, segfault:

dock6 -i rigid.in -o rigid out

dock6[3602]: segfault at 00002b4da6e0c000 rip 000000000043ffd1 rsp
00007fff86593bc0 error 6
Segmentation fault
---------------------------


Thanks
francesco pietra





__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: errors.out.tar.bz2
Type: application/x-bzip
Size: 767 bytes
Desc: pat110858221
Url : http://blur.compbio.ucsf.edu/pipermail/dock-fans/attachments/20071107/13b481a1/attachment.bin 


More information about the Dock-fans mailing list