[Dock-fans] bash:sphgen: command not found (Again!)

Carlo Zambonelli zambonel at fas.harvard.edu
Wed Apr 23 10:02:19 PDT 2008


Dear Dock-fans,
I am new to cygwin, to linux and to Dock, so please be patient and if
necessary redirect me to "required readings" in addition to anything I
can find on the Dock web page, which I already read.
I successfully installed Cygwin, Dock6.2 and DMS. I completed the
tutorial Structure Preparation and I am working on the tutorial Sphere
Generation and Selection. I ran DMS successfully and now I have rec.ms
and INSPH in my working directory. When I run sphgen I obtain the
following error:

bash: sphgen: command not found

sphgen.exe is located in directory /usr/local/dock6/bin. If I run sphgen
from this directory I obtain the following message:

open: No such file or directory
apparent state: unit 5 named INSPH
lately writing direct unformatted external IO
Segmentation fault (core dumped)

The first line correctly tells me that I do not have the INSPH file in
this directory. What is the meaning of the remaining of the message? It
looks like I can not launch sphgen from my working directory, as I
expected. When I ran DMS from the same working directory everything went
smoothly.

I read all the threads dealing with this problem at no avail: I tried to
make the sphgen.exe executable with the command

chmod 755 sphgen

For sake of completeness of information:

-- sphgen is located in the following directory:

usr/local/Dock6/bin

-- DMS is located in:

usr/local/dms

-- my working directory is:

/usr/local/dock6/tutorials/struct_prep

Any help would be greatly appreciated!

Carlo


More information about the Dock-fans mailing list