[Dock-fans] bash:sphgen: command not found (Again!)

Scott Brozell sbrozell at scripps.edu
Wed Apr 23 13:49:03 PDT 2008


Hi,

On Wed, 23 Apr 2008, Carlo Zambonelli wrote:

> I am new to cygwin, to linux and to Dock, so please be patient and if
> necessary redirect me to "required readings" in addition to anything I
> can find on the Dock web page, which I already read.
> I successfully installed Cygwin, Dock6.2 and DMS. I completed the
> tutorial Structure Preparation and I am working on the tutorial Sphere
> Generation and Selection. I ran DMS successfully and now I have rec.ms
> and INSPH in my working directory. When I run sphgen I obtain the
> following error:
> 
> bash: sphgen: command not found
> 
> sphgen.exe is located in directory /usr/local/dock6/bin. If I run sphgen

Add /usr/local/Dock6/bin to your path:
bash-2.05b$ export PATH="$PATH:/usr/local/Dock6/bin"
Or use the full path:
/usr/local/Dock6/bin/sphgen.exe


> from this directory I obtain the following message:
> 
> open: No such file or directory
> apparent state: unit 5 named INSPH
> lately writing direct unformatted external IO
> Segmentation fault (core dumped)
> 
> The first line correctly tells me that I do not have the INSPH file in
> this directory. What is the meaning of the remaining of the message? It

The middle two are Fortran messages specifying the file
and the type of input/output.
Googgle fortran io if you want more info.
http://nostalgia.wikipedia.org/wiki/Segmentation_fault


Scott

> looks like I can not launch sphgen from my working directory, as I
> expected. When I ran DMS from the same working directory everything went
> smoothly.
> 
> I read all the threads dealing with this problem at no avail: I tried to
> make the sphgen.exe executable with the command
> 
> chmod 755 sphgen
> 
> For sake of completeness of information:
> 
> -- sphgen is located in the following directory:
> 
> usr/local/Dock6/bin
> 
> -- DMS is located in:
> 
> usr/local/dms
> 
> -- my working directory is:
> 
> /usr/local/dock6/tutorials/struct_prep



More information about the Dock-fans mailing list