[Dock-fans] parallel dock

inderjit yadav inderjitbioinfo at gmail.com
Sat Apr 26 21:39:23 PDT 2008


hello

I have installed the parallel version of dock6.2 .all the programs are
installed but it is not running the dock program all other programs are
running smoothly
path of installed directory
          /export/apps/dock/dock6

i used  command

 mpirun -np 4 dock6.mpi -i mpi.in

it shows

Initializing MPI Routines...
Initializing MPI Routines...
Initializing MPI Routines...
p0_5543:  p4_error: semget failed for setnum: 17
-----------------------------------------------------------------------------
It seems that [at least] one of the processes that was started with
mpirun did not invoke MPI_INIT before quitting (it is possible that
more than one process did not invoke MPI_INIT -- mpirun was only
notified of the first one, which was on node n0).
mpirun can *only* be used with MPI programs (i.e., programs that
invoke MPI_INIT and MPI_FINALIZE).  You can use the "lamexec" program
to run non-MPI programs over the lambooted nodes.
-----------------------------------------------------------------------------
p0_5541:  p4_error: interrupt SIGx: 15
p0_5542:  p4_error: interrupt SIGx: 15

and terminates

as my executables are not in the system path I used

 mpirun -np 4 dock6.mpi -i mpi.in

then again after some times shows the same error


would anyone please help me in running the dock parallelly i need it in my
project .



inderjit
M.Sc Bioinformatics.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://blur.compbio.ucsf.edu/pipermail/dock-fans/attachments/20080426/dcfa9b28/attachment.html 


More information about the Dock-fans mailing list