[Dock-fans] DOCK 6.4 on Mac OSX?

Scott Brozell sbrozell at rci.rutgers.edu
Wed Jun 29 17:29:07 PDT 2011


Hi,

It is likely that using gfortran, as Prashant suggested,
will resolve this issue.  
You should first verify that your fortran compiler works on a
simple program:
http://www.mesoscale.iastate.edu/agron505/fort_1.htm
Also be sure to clean dock before rebuilding it:
cd install; make realclean; make

Although installing Dock is simpler than installing Amber,
if you encounter further problems there may be useful advice here:
http://amberonmac.blogspot.com/

scott

btw
DOCKBUILDFLAGS is for interactive use (on the command line)
and should not be defined in config.h

On Wed, Jun 29, 2011 at 09:32:59AM +0530, Prashant Kumar wrote:
> Dear Brent,
>
> Use gfortran instead of using g77. Edit config.h file in line FC = g77 to FC
> = gfortran. Hope this will solve your problem.
>

On Tue, Jun 28, 2011 at 12:10:14PM -0400, Brent R. Stockwell wrote:
> Hi folks. I am trying to install DOCK 6.4 on Mac OSX (10.6.8, 2x 3 GHz Quad-Core Intel Xeon).
> 
> I have not been able to get the install to work. I followed the directions in the manual, but when I originally tried the "make all" command, I was getting an error related to the lack of g77 compiler. So I was able to download and install g77, but I was still getting a bunch of errors abut the architecture not being correct:
> 
> ld: warning: -macosx_version_min not specificed, assuming 10.6
> ld: warning: ignoring file grid.o, file was built for unsupported file format which is not the architecture being linked (i386)
> ld: warning: ignoring file score.o, file was built for unsupported file format which is not the architecture being linked (i386)
> etc.
> 
> Then, eventually I get this error:
> 
> Undefined symbols for architecture i386:
>   "_MAIN__", referenced from:
>       _main in libfrtbegin.a(frtbegin.o)
> ld: symbol(s) not found for architecture i386
> collect2: ld returned 1 exit status
> make[2]: *** [grid] Error 1
> make[1]: *** [utils] Error 2
> make: *** [install] Error 2
> 
> I found this discussion on the DOCK-fans archive:
> 
> http://mailman.docking.org/pipermail/dock-fans/2011-April/002512.html
> 
> and tried modifying the config.h file as suggested, but it did not help. I couldn't figure out how to modify the DOCKBUILDFLAGS as suggested there, since I didn't see that in the config.h file.
> 
> I then found this thread on the DOCK-fans archive:
> 
> http://mailman.docking.org/pipermail/dock-fans/2008-August/001699.html
> 
> which suggested I should modify the config.h file by editing the LIBS definition to:
> 
> LIBS=        -lm -lpthread -lSystemStubs -L/usr/lib/gcc/powerpc-apple-darwin8/4.0.1 -lgcc
> 
> So I did (replacing powerpc-apple-darwin8/4.0.01 with the correct file name on my system). But I am still getting this architecture i386 error.
> 
> Has anyone successfully installed DOCK 6.4 on Mac OSX 10.6.8, and if so, do you have a protocol for how you did it?
> 


More information about the Dock-fans mailing list