[Dock-fans] g77 not found

Scott Brozell sbrozell at rci.rutgers.edu
Sun Apr 15 02:16:09 PDT 2012


Hi,

You need to install the appropriate compiler package,
either g77 or gfortran, just like you did for g++ :
https://help.ubuntu.com/community/InstallingCompilers

If you use gfortran then edit dock6/install/config.h
and follow the direction near the top:
# If g77 is not available then change FC below to gfortran or g95.

scott

On Sun, Apr 15, 2012 at 10:30:48AM +0530, Nutan Preety wrote:
> I am trying to install Dock 6.5 on Ubuntu. I have created "config.h" by
> running "./configure gnu". installed flex and g++. but when i run "make"
> its showing error:
> 
> make[3]: Leaving directory `/home/nutan/Desktop/dock6/src/dock/nab'
> g++ -O2 -o dock6 filter.o amber_typer.o base_grid.o base_mpi.o base_score.o
> conf_gen.o dock.o dockmol.o grid.o library_file.o master_score.o orient.o
> score.o score_descriptor.o simplex.o sphere.o score_solvent.o score_amber.o
> sasa.o score_chemgrid.o utils.o trace.o nab/*.o -lm -lpthread
> mv dock6 ../../bin
> make[2]: Leaving directory `/home/nutan/Desktop/dock6/src/dock'
> cd accessories && make install
> make[2]: Entering directory `/home/nutan/Desktop/dock6/src/accessories'
> g77 -c -O2 -fno-automatic -fno-second-underscore -o showbox.o  showbox.f
> make[2]: g77: Command not found
> 
> I have tried to replace g77 with gfortran but still getting the same error
> with gfortran too.


More information about the Dock-fans mailing list