[Dock-fans] cofactors in dock

Scott Brozell sbrozell at rci.rutgers.edu
Tue May 22 12:06:14 PDT 2012


> > WARNING assign_vdw_labels: Atom valence violated for 1SA0.pdb **** GTP 847 C8 6523.

In Dock 6.5, grid was modified so that this message provides more detail;
(in addition, the behavior was changed so that execution continues,
but it is important to understand the source of this problem because
it is usually an input preparation failure).

If you don't want to upgrade to 6.5 then you could add more detail to
the fprintf statement starting on line 318.  This form has even more
detail than in 6.5:
      if (k > label_vdw->member[molecule->atom[i].vdw_id].valence)
        fprintf (global.outfile,
          "WARNING assign_vdw_labels: Atom valence exceeded by %d - %d for \n"
          "%s %s %s %d %s %d;\nusing "
          "vdw parameter definition %s named %s.\n",
          k, label_vdw->member[molecule->atom[i].vdw_id].valence,
          molecule->atom[i].subst_id + 1,
          molecule->atom[i].name, i + 1,
          label_vdw->member[molecule->atom[i].vdw_id].name );

> >> I have used gtp prep and frcmod files from the database

It looks like you are mixing together Amber and Dock preparation.
That will not work for DOCKing.
Without knowing the exact programs and sequences of commands used,
I cannot be sure, but this is likely the source of your problem.
For DOCK preparation, have you tried using only Chimera 1.6.1 dockprep ?


On Tue, May 22, 2012 at 10:15:16AM -0700, Eric Pettersen wrote:
> On May 22, 2012, at 12:09 AM, Mary Varughese wrote:
> > I have installed the new chimera release 1.6.1 and the initial setups like preparing rec_charged .mol2 file went fine. But on grid generation it fails with the same error message
> > Reading in coordinates of receptor.
> > WARNING assign_vdw_labels: Atom valence violated for 1SA0.pdb **** GTP 847 C8 6523.
> > Error reading in receptor." The number of atoms in GTP are the same as in the gtp.prep of the database. I dont understand where does the valency violated.
> Hi Mary,
> 	This is an error from DOCK.  I have cc'ed dock-fans on this so that someone there can reply, since I have no idea myself.  Certainly if the complaint is about atom C8 in GTP in 1SA0, the valence of GTP C8 (as prepared by Chimera) looks fine to me.
> > Also did anyone knows where the gtp contributed values are stored in the chimera folders.
> The charges and atom types for GTP are stored in <your Chimera installation>/share/AddCharge/dict.py.  These are the only GTP-specific values stored by Chimera.
> --Eric
> > On Sat, May 19, 2012 at 2:47 PM, Mary Varughese <maryvj1985 at gmail.com> wrote:
> > thank you. i will try it.
> > 
> > On Fri, May 18, 2012 at 11:27 PM, Eric Pettersen <pett at cgl.ucsf.edu> wrote:
> > Hi Mary,
> > At the time that old chimera-users message was written, the GTP-lookup charges were only available in daily builds.  They are now available in the 1.6.1 production release.  You can download that release by going to the Chimera home page (www.cgl.ucsf.edu/chimera) and following the "Download" link.  You should also be able to get there by starting up your 1.5.3 version and in its Help menu choose "Check for Updates".  There will be a button to take you to the download page on the resulting dialog.
> > 
> > 
> > On May 17, 2012, at 10:49 PM, Mary Varughese wrote:
> > 
> >> I have used gtp prep and frcmod files from the database
> >> "<http://www.pharmacy.manchester.ac.uk/bryce/amber/>"
> >> and using leap in AMBER created the .mol2 file. After using dockprep tool i loaded the gtp.mol2(containing charges) and write the combined rec_charged.mol2 file. and continue the the steps but at the grid generation step it fails saying "Reading in coordinates of receptor.
> >>> WARNING assign_vdw_labels: Atom valence violated for 1SA0.pdb (combined)
> >> **** GTP 848 C8 13145."
> >> 
> >> I am using chimera 1.5.3
> >> Also i didnt see any 1.6.1 release. what are these daily builds. How they are applied.
> >> 
> >> Infact my problem is that my ligand on docking occupies the GTP binding site. So i want to try with gtp included receptor so that it takes another suitable position.
> >> 
> >> On Fri, May 18, 2012 at 2:15 AM, Eric Pettersen <pett at cgl.ucsf.edu> wrote:
> >> Yes, if you use the 1.6.1 release of Chimera, GTP is treated as a "standard" residue in that Chimera knows what the charges are for each atom without having to call antechamber to compute them (that computation typically fails with highly negatively charged molecules like GTP).
> >> 
> >> On May 17, 2012, at 12:50 PM, Scott Brozell wrote:
> >>> On Wed, May 16, 2012 at 03:22:11PM +0530, Mary Varughese wrote:
> >>>> I have to include the cofactor GTP as part of my receptor protein and dock
> >>>> with a ligand. But chimera is not allowing to prepare rec_charged.mol2 file
> >>>> since it fails at finding amibcc charge method for GTP residue. Then i
> >>>> separately prepared the mol2 file for GTP (using gtp.prep and gtp.frcmod)
> >>>> and after performing dockprep on the receptor i opened the GTP.mol2 file in
> >>>> the same window and write the mol2 file. but again at grid generation it
> >>>> fails "Reading in coordinates of receptor.
> >>>> WARNING assign_vdw_labels: Atom valence violated for 1SA0.pdb (combined)
> >>>> **** GTP 848 C8 13145.
> >>>> Error reading in receptor."
> >>> 
> >>> Which version of chimera are you using ?
> >>> There was some recent activity for GTP but using Gasteiger charges:
> >>> http://plato.cgl.ucsf.edu/pipermail/chimera-users/2011-October/006846.html
> >>> 
> >>> Are you saying that you ran antechamber separately from chimera
> >>> and got the am1bcc charges for gtp ?

More information about the Dock-fans mailing list