[Dock-fans] Installation of DOCK 6.6 on a Mac

Scott Brozell sbrozell at rci.rutgers.edu
Tue Jan 28 00:12:20 PST 2014


Hi,

Can you verify that the gcc -v output is the same as that below
for gfortran -v ?

scott

On Mon, Jan 27, 2014 at 06:30:02PM +0000, msmith at mcdaniel.edu wrote:
> This is Chris again, trying to help Marilyn get this thing going. In order
> to be as close to the situation that is in the link that you provided, we
> upgraded from 10.8.5 to 10.9.1 and downloaded the 4.9 version of GCC. We
> downloaded the installer for DOCK6 again and tried recompiling and we get
> the exact same result. Really not sure where to go from here, so if you
> have any more suggestions for how we can get this to stop giving us these
> errors, it would be greatly appreciated. Here is the output from the
> commands that you asked us to run:
> 
> msmithmac:install marilynsmith$ gcc -v
> Configured with: --prefix=/Applications/Xcode.app/Contents/Developer/usr
> --with-gxx-include-dir=/Applications/Xcode.app/Contents/Developer/Platforms
> /MacOSX.platform/Developer/SDKs/MacOSX10.9.sdk/usr/include/c++/4.2.1
> Apple LLVM version 5.0 (clang-500.2.79) (based on LLVM 3.3svn)
> Target: x86_64-apple-darwin13.0.0
> Thread model: posix
> 
> msmithmac:install marilynsmith$ gfortran -v
> Using built-in specs.
> COLLECT_GCC=gfortran
> COLLECT_LTO_WRAPPER=/usr/local/libexec/gcc/x86_64-apple-darwin13.0.0/4.9.0/
> lto-wrapper
> Target: x86_64-apple-darwin13.0.0
> Configured with: ../gcc-4.9-20131215/configure
> --enable-languages=c++,fortran
> Thread model: posix
> gcc version 4.9.0 20131215 (experimental) (GCC)
> 
> On 1/24/14, 10:24 PM, "Scott Brozell" <sbrozell at rci.rutgers.edu> wrote:
> >On Fri, Jan 24, 2014 at 06:45:15PM +0000, msmith at mcdaniel.edu wrote:
> >> I am a tech who is trying to help Marilyn get this installation figured
> >>out. Here is the full output of the command with the warnings and errors
> >>highlighted. Does that give you any more to go on in helping us to
> >>figure out where this is getting hung up?
> >> 
> >> Starting installation of
> >> DOCK v6.6
> >> at Fri Jan 24 13:37:26 EST 2014.
> >> 
> >> cd ../src && make install
> >> cd dock && make install
> >> g++ -c -O2 -o score_chemgrid.o score_chemgrid.cpp
> >> In file included from score_chemgrid.cpp:38:
> >> In file included from ./tnt/tnt.h:41:
> >> ./tnt/tnt_array1d.h:238:15: warning: '&&' within '||'
> >>[-Wlogical-op-parentheses]
> >> if ((i0 > 0) && (i1 < n_) || (i0 <= i1))
> >> ~~~~~~~~~^~~~~~~~~~~~ ~~
> >> ./tnt/tnt_array1d.h:238:15: note: place parentheses around the '&&'
> >>expression to silence this warning
> >...
> >> In file included from score_chemgrid.cpp:38:
> >> In file included from ./tnt/tnt.h:55:
> >> ./tnt/tnt_sparse_matrix_csr.h:97:3: error: no matching constructor for
> >>initialization of 'Array1D<int>'
> >> rowptr_(M, r), colind_(nz, c), dim1_(M), dim2_(N) {}
> >> ^ ~~~~
> >> ./tnt/tnt_array1d.h:63:11: note: candidate constructor not viable: no
> >>known conversion from 'const int *' to
> >> 'const int' for 2nd argument; dereference the argument with *
> >> Array1D(int n, const T &a);
> >> ^
> >> ./tnt/tnt_array1d.h:64:11: note: candidate constructor not viable: 2nd
> >>argument ('const int *') would lose
> >> const qualifier
> >> Array1D(int n, T *a);
> >> ^
> >> ./tnt/tnt_array1d.h:61:11: note: candidate constructor not viable:
> >>requires 0 arguments, but 2 were provided
> >> Array1D();
> >> ^
> >> ./tnt/tnt_array1d.h:62:11: note: candidate constructor not viable:
> >>requires single argument 'n', but 2
> >> arguments were provided
> >> explicit Array1D(int n);
> >> ^
> >> ./tnt/tnt_array1d.h:65:14: note: candidate constructor not viable:
> >>requires single argument 'A', but 2
> >> arguments were provided
> >> inline Array1D(const Array1D &A);
> >> ^
> >...
> >> 2 warnings and 2 errors generated.
> >> make[2]: *** [score_chemgrid.o] Error 1
> >> make[1]: *** [dock6] Error 2
> >
> >The errors above are the same as those reported in an attachement to
> >http://mailman.docking.org/pipermail/dock-fans/2013-December/002868.html
> >wherein the user reported that the source of the problem was an
> >inconsistent
> >compiler installation; the fix was to install a newer version at
> >http://hpc.sourceforge.net
> >
> >For my interest, please report the versions you have:
> >% gcc -v
> >% gfortran -v


More information about the Dock-fans mailing list